Tajpi - Klavarilo por esperantistoj

 Home Tajpi - Klavarilo por esperantistoj
por Windows 2000 / XP / Vista / 7 / 8 / 10

En la esperanta alfabeto estas ses supersignaj literoj kiuj ne estas entajpeblaj per normalaj klavaroj. Tajpi estas programo por facile tajpi tiujn literojn sen modifi la sistemon.

Dum Tajpi funckias en via komputilo vi povas:

- Uzi klavkombinojn kiel sx, gh, u^ ktp - ili aŭtomate anstataŭiĝos per la konvena esperanta litero dum vi tajpas.
- Aperigi esperantan literon per premo de unuopa klavo. Tio simulas reagordon de la sistema klavarfasono.
- Uzi Alt Gr kune kun alia klavo por aperigi esperantajn literojn.
- Simuli la "senpaŝajn klavojn" kiuj ekzistas en iuj klavarfasonoj.
- Skripti klavkomandojn kiuj aktivigas plurajn funkciojn, ekzemple konverti tekston de la X-sistemo aŭ aperigi Unikodajn simbolojn.

Tajpi neniel ajn modifos vian sistemon; ĝi nur sidas en la fono kaj respondas al klavara tajpado. Ĝi estas libera softvaro, eldonata kun sia fontkodo laŭ la kondiĉoj de la GNU GPL versio 3.

  • Instalado
  • Agordo
  • Historio de ŝanĝoj

© 2008- Thomas James Ĝisdatiĝis je 10-jun-2016
tmj2005@gmail.com


Tajpi - Instalado

 Home Tajpi - Klavarilo por Esperantistoj
Instalado de la programo

1. Elŝutu la instalilon kaj alklaku la bildeton de la dosiero. Aperos la instalofenestro:

2. Alklaku "Next" por komenci la instalon.
3. Akceptu la kondiĉojn de la GPL kaj alklaku "Next".
4. Entajpu la nomon de la dosierujo en kiun Tajpi estu instalita, aŭ lasu ĝin se C:\Program Files\Tajpi plaĉas al vi.
5. Alklaku "Next".
6. Elektu la bildsimbolojn kiuj estu metitaj sur la skribtablon (desktop) aŭ en la rapidlanĉan breton (quick launch bar).
7. Alklaku "Install".

La programo instaliĝos kaj estos preta por uzi. Vi povas komenci Tajpi per elekto de "Launch Tajpi" je la fino de la instalado, aŭ per alklako de la bildsimbolo de Tajpi.

  • ← Hejmen
  • Agordo
  • Historio de ŝanĝoj

© 2008- Thomas James Ĝisdatiĝis je 10-jun-2016
tmj2005@gmail.com


Tajpi - Agordo

 Home Tajpi - Klavarilo por esperantistoj
Agordo de la programo

Ĉi tiu paĝo enhavas instrukciojn por agordi Tajpi. Por informoj pri TajpiSkripto bonvolu iri ĉi tien.

Kiam Tajpi unuafoje ekfunkcias, ĝi petas ke vi agordu ĝin. Jen la agordofenestro:

  • Rektaj klavoj - Ligi supersignajn esperantajn literojn al rektaj, unuopaj klavoj. Kiam tajpiĝas la klavo, aperas la supersigna litero. Por entajpi la rektan klavliteron mem, premu Alt Gr (aŭ Ctrl+Alt) dum premo de la klavo.
  • Prefiksoj - Supersigna litero aperas kiam c, g, h, j, s aŭ u tajpiĝas tuj post prefiksa simbolo.
  • Igi malvidebla la prefiksan literon - Prefiksaj literoj ne aperas kiam ili entajpiĝas. Por aperigi la prefikson, tajpu Space tuj poste, aŭ tajpu iun ajn nesupersigneblan simbolon por aperigi ĝin kune kun la prefikso. Tio simulas la konduton de la tielnomataj senpaŝaj klavoj kiuj ekzistas en multaj klavarfasonoj.
  • Sufkisoj - Kiam unu el la elektitaj sufiksoj entajpiĝas tuj post c, g, h, j, s aŭ u, la litero ricevas supersignon. Defaŭlte la sufiksoj enhavas H, sed parolantoj de aliaj lingvoj (ekzemple la angla) eble volos elpreni ĝin por ke supersignoj ne aperu je tajpo de "ch", "sh" ktp.
  • Ripeto de sufikso forigas supersignon - Retajpo de la sama sufikso uzita por supersigni la literon forigas la supersignon.
  • Alt Gr + litero kiu ricevas supersignon - Premo de Alt Gr (aŭ Ctrl+Alt) kune kun c, g, h, j, s aŭ u aperigas supersignan literon. Ekzemple Alt Gr+C aperigas ĉ.
  • Aŭtomata aŭ/eŭ - Litero u tajpita post a aŭ e aperas kiel ŭ.
  • w por ŭ - Litero w estas uzata anstataŭ u por aperigi ŭ. Tio estas utila se estas konflikto kun metodo en la sistema klavarfasono por alie supersigni u.
  • Unikodo / Latina-3 - Supersignaj literoj venas el signaro aŭ Unikodo aŭ Latina-3. Pli rekomendinda estas Unikodo. Inkludita estas Latina-3 por tiuj kiuj volas ankoraŭ uzi siajn malnovajn tiparojn de Latin-3, aŭ programojn kiuj ne plene subtenas Unikodon.
  • Alglui literon el tondujo - Anstataŭ sendiĝi rekte al la sistemo, supersignaj literoj pasas al la tondujo (clipboard) kaj algluiĝas el ĝi.

    Apud ĉi tiu opcio estas butono, klako je kiu aperigas fenestron per kies opcioj oni povas elekti la metodon, kiun Tajpi uzu kiam ĝi algluas la supersignan literon el la tondujo. Jen la fenestro:
    Rekomendinda estas Shift+Insert sed Ctrl+V estas ebla alternativo kaj probable ne kaŭzos problemon.

    Kiam litero pasas al la tondujo la jama enhavo forviŝiĝas. Sed eblas remeti la enhavon de la tondujo per la opcio "Remeti enhavon de tondujo post algluo"; kiam elektita, la tonduja enhavo estas remetita post tiom da milisekundoj, kiom specifitaj en la tekstkampo "Post milisekundoj". Bonvolu rimarki ke ĉi tio funkcias por nur teksto. Dosierojn, bildojn kaj aliajn datumspecojn Tajpi ne subtenas.
  • HTML-aj surogatoj - Tajpi enigas HTML-an surogaton anstataŭ la supersignan literon. Ekzemple &#265; anstataŭ ĉ. Utila ileto por retverkistoj.
  • Starti aktiva - Kiam Tajpi komenciĝas ĝi estas en aktiva stato.
  • Aŭtomata starto - Tajpi aŭtomate komenciĝas kun Windows.
  • Klavkomando - Agordo por la klavkomando kiu ŝaltas/malŝaltas Tajpi.
  • Lingvo - Klako al flagoj Esperanta Flago kaj Angla Flago ŝanĝas la lingvon de la interfaco inter Esperanto kaj la angla.
  • Instalado
  • ← Hejmen
  • Historio de ŝanĝoj

© 2008- Thomas James Ĝisdatiĝis je 10-jun-2016
tmj2005@gmail.com


Tajpi - Skripto

 Home Tajpi - Klavarilo por esperantistoj
Skripto

TajpiSkripto provizas pli potencan agordon kaj ilojn por konverti/enigi tekston. Ĝi uzas simplan sintakson por agordi klavkomandojn kiujn oni povas aktivigi iam ajn per la klavaro. La skripto-dosiero nomiĝas Tajpi.skr kaj restas en la dosierujo de la programo, kiu defaŭlte estas C:\Program Files (x86)\Tajpi.

En la jena ekzemplo, la klavkomando Ctrl+R ŝaltas/malŝaltas transliterumadon de rusaj literoj. La signo [^] reprezentas la klavon Ctrl, kiun oni nomas modifilo:

^R::rusa

Por uzi pli ol unu modifilon en klavkomando, apudigu ilin sinsekve (la ordo ne gravas). La jena ekzemplo uzas ^!S por indiki Ctrl+Alt+S, kaj aktivigas cirilan transliterumadon.

^!S::cirila

La jenaj modifilaj simboloj uzeblas por difini klavkomandon:

Simbolo | Priskribo
! | Alt
^ | Control
+ | Shift
< | Uzi la maldekstran klavon el la paro. e.g. <!a samas kiel !a, sed nur la maldekstra klavo aktivigas ĝin.
> | Uzi la dekstran klavon el la paro.

Eblas tute ellasi modifilojn el klavkomando kaj ligi al unuopa klavo. Ekzemple la jena klavkomando montras la agordofenestron je premo de F12:

F12::agordi

TajpiSkripto ne atentas usklecon. La jenaj paroj de klavkomandoj agas tute same:

^+a::agordi
^+A::AGORDI
>!sPaCe::cIRIla
>!SpAcE::CiriLA

Ĉion post punktokomo Tajpi traktas kiel komenton, kaj ignoras:

;ĉi tio estas komento
^+insert::rusa  ;ĉi tiu klavkomando estas aktiva
;^+space::rusa   kaj ĉi tiu ne

La nomon de la klavo post la modifiloj oni literumu laŭ la klavnomoj en la menuo ĉe la fundo de la agordofenestro de Tajpi (kvankam eblas ellasi spacojn).

La jenaj komandoj uzeblas en klavkomando:

Komando | Priskribo
cirila Ŝaltas/malŝaltas transliterumadon de Esperantaj literoj al cirilaj. Kiam esperanta litero tajpiĝas, ĝi aŭtomate aperas kiel la plej fonetike simila litero el la cirila alfabeto. Jen la skemo:
a а | b б | c ц | ĉ ч | d д | e е | f ф | g г | ĝ ѓ | h х | ĥ ћ | i и | j й | ĵ ж | k к | l л | m м | n н | o о | p п | r р | s с | ŝ ш | t т | u у | ŭ ў | v в | z з
A А | B Б | C Ц | Ĉ Ч | D Д | E Е | F Ф | G Г | Ĝ Ѓ | H Х | Ĥ Ћ | I И | J Й | Ĵ Ж | K К | L Л | M М | N Н | O О | P П | R Р | S С | Ŝ Ш | T Т | U У | Ŭ Ў | V В | Z З
rusa Ŝaltas/malŝaltas transliterumadon de Esperantaj literoj al rusaj. Kiam esperanta litero tajpiĝas, ĝi aŭtomate aperas kiel la plej fonetike simila litero (aŭ literkombino) el la rusa alfabeto. Jen la skemo, kun la malsamaĵoj kompare kun la cirila skemo koloritaj ruĝe:
a а | b б | c ц | ĉ ч | d д | e е | f ф | g г | ĝ дж | h х | ĥ х | i и | j й | ĵ ж | k к | l л | m м | n н | o о | p п | r р | s с | ŝ ш | t т | u у | ŭ у | v в | z з
A А | B Б | C Ц | Ĉ Ч | D Д | E Е | F Ф | G Г | Ĝ ДЖ | H Х | Ĥ Х | I И | J Й | Ĵ Ж | K К | L Л | M М | N Н | O О | P П | R Р | S С | Ŝ Ш | T Т | U У | Ŭ У | V В | Z З
ssigi_elektitan | Konvertas la elektitan tekston de X-sistemo al supersignaj esperantaj literoj. Uzeblas en tekstkampo aŭ ajna tekstredaktilo kiel Word aŭ Notepad.
ssigi_tondujon | Konvertas la tekston en la tondujo de X-sistemo al supersignaj esperantaj literoj.
xigi_elektitan | Konvertas supersignajn literojn en la elektita teksto al X-sistemo.
xigi_tondujon | Konvertas supersignajn literojn en teksto en la tondujo al X-sistemo.
higi_elektitan | Konvertas supersignajn literojn en la elektita teksto al H-sistemo.
higi_tondujon | Konvertas supersignajn literojn en teksto en la tondujo al H-sistemo.
htmligi_elektitan | Konvertas ĉiujn simbolojn en la elektita teksto al HTML-aj surogatoj. Tio ankaŭ povas esti utila por ekscii la unikodan numeron de iu simbolo, aŭ serio de simboloj.
htmligi_tondujon | Konvertas ĉiujn simbolojn en la teksto en la tondujo al HTML-aj surogatoj.
### La komando povas esti numero kiu reprezentas ajnan unikodan simbolon. Tiun simbolon Tajpi enigas je premo de la klavkomando. La jena klavkomando enigas Ĉ je premo de Ctrl+Alt+C:
^!C::264
Eblas specifi hex-numeron per prefikso de "&H". La jena klavkomando sendas la simbolon ♥:
^!K::&H2665
Ankaŭ eblas specifi plurajn simbolojn en unuopa klavkomando, per apartigo per komo. La jena klavkomando enigas AAA:
^!A::65,65,65
Vidu ĉi tie por kompleta listo de unikodaj simboloj.
_[text] La komando povas esti peco de teksto por enigi en la sistemon. La teksto devas havi substrekon antaŭ ĝi. La jena klavkomando enigas eĥoŝanĝo ĉiuĵaŭde je premo de Alt+E:
!E::_eĥoŝanĝo ĉiuĵaŭde
Eblas uzi kodŝanĝajn signojn: \n por nova linio kaj \t por tabo. Necesas meti malsuprenstrekon antaŭ malsuprenstrekoj kaj punktokomoj, por ke ili ne traktiĝu kiel kodŝanĝa simbolo aŭ komentosigno.
agordi | Montras la agordofenestron de Tajpi.
alglui | Ŝaltas/malŝaltas la opcion "Alglui el tondujo" en la agordofenestro.
english | Ŝanĝas la lingvon de la interfaco al la angla.
esperanto | Ŝanĝas la lingvon de la interfaco al Esperanto.
eliri | Ĉesigas Tajpi.
helpo | Montras la helpodosieron en la lingvo de la interfaco.
helpo_en | Montras la anglan holpodosieron.
helpo_eo | Montras la esperantan helpodosieron.
html | Ŝaltas/malŝaltas la opcion "HTML-aj surogatoj" en la agordofenestro.
klavkomando | Ŝaltas/malŝaltas Tajpi. Klavkomando por ĉi tio jam ekzistas en la agordofenestro, sed eblas starigi pliajn.
latina3 | Ŝaltas la opcion "Latina-3" en la agordofenestro.
pri_tajpi | Montras la fenestron "Pri Tajpi".
skripto | Ŝaltas/malŝaltas TajpiSkripton.
unikodo | Ŝaltas la opcion "Unikodo" en la agordofenestro.

Post redakto de skripto necesas konservi la skriptodosieron kaj rekomenci Tajpi. Notu ke TajpiSkripto agnoskas dosierojn nur en formatoj ASCII kaj UTF-8. Aliajn formatojn de Unikodo ĝi ne subtenas.

  • ← Agordo

© 2008- Thomas James Ĝisdatiĝis je 10-jun-2016
tmj2005@gmail.com


Tajpi - Historio

 Home Tajpi - Klavarilo por esperantistoj
Historio de ŝanĝoj

2.98 (10-jun-16):
  • Ĝisdatigis diversajn informojn en la paĝaro, programo kaj subtenaj dosieroj.
2.97 (26-feb-12):
  • Aldonis opcion "w por ŭ".
  • Iom modifis la transliteruman skemon por rusaj/cirilaj literoj. Por vidi la novan skemon vidu instrukciojn de TajpiSkripto.
  • Faris kelkajn aldonojn kaj korektis kelkajn eraretojn en la helpdosieroj.
2.96 (15-aŭg-11):
  • Elprenis la klavon Win el la listo de modifilaj klavoj, en TajpiSkripto.
2.95 (14-aŭg-11):
  • Aldonis komandojn "htmligi_elektitan" kaj "htmligi_tondujon" al TajpiSkripto.
2.94 (12-aŭg-11):
  • TajpiSkripto nun permesas enigon de linioj de teksto je premo de klavkomando.
  • Aldonis komandon "skripto" al TajpiSkripto, kiu ŝaltas/malŝaltas ĝin.
  • Riparis cimon kiu kaŭzis problemon dum prilaboro de skriptodosiero konservita en formato ANSI.
2.93 (10-aŭg-11):
  • TajpiSkripto nun permesas enigon de pluraj unikodaj simboloj per unu klavkomando. Necesas nur apartigi la simbolojn per komo.
  • Korektis cimon en TajpiSkripto kiu malaktivigis iujn klavkomandojn de Windows kiuj uzas la klavon Win.
  • Korektis eraron en la helpodosiero de TajpiSkripto. Komando "halti" nun estas "eliri".
2.92 (08-aŭg-11):
  • Riparis cimon en TajpiSkripto, kiu kaŭzis ke premo de la klavo Win montris la komenc-menuon, eĉ se estas klavkomando ligita al tiu klavo.
2.91 (07-aŭg-11):
  • Aldonis "Tajpi-Skripton". Vidu la helpopaĝon de agordo por instrukcioj.
  • Transliterumo al rusaj/ciriaj literoj nun estas traktata de Tajpi-Skripto kaj estas defaŭlte malaktiva. Por aktivigi, senkomentigi la necesajn liniojn en Tajpi.skr en la dosierujo de Tajpi, kaj agordu preferan klavkomandon.
  • Ctrl+Alt nun estas uzebla kiel alternativo al Alt Gr.
  • Ordigis HTML en helpdosieroj kaj korektis erarojn.
  • Korektis tekston en la interfaco de Tajpi.
  • Riparis malgrandan cimon en la klavkomando de Tajpi.
  • Ordigis fontkodon.
2.90 (13-apr-11):
  • Korektis literuman eraron en la agordofenestro: "Automata aŭ/eŭ" al "Aŭtomata aŭ/eŭ".
2.89 (08-apr-11):
  • Korektis malgrandan cimon kiu kaŭzis la opcion "Ripeto de sufikso forigas supersignon" iafoje funkcii malĝuste.
2.88 (07-apr-11):
  • Korektis grandegan cimaĉon kiu kaŭzis ke supersignoj aperis en iuj multfadenaj programoj, eĉ kiam la klavaranĝo uzata ne enhavas supersigneblajn esperantajn literojn.
  • Korektis cimon kiu iafoje kaŭzis ke aperis sistema menuo super la menuo de Tajpi, je dekstra klako al la bildsimbolo en la taskopleto.
  • Korektis cimon kiu iafoje kaŭzis la opcion "Ripeto de sufikso forigas supersignon" malĝuste funkcii.
  • Inversigis la sonojn por ŝalto/malŝalto de la programo.
  • Aldonis bildsimbolo por Tajpi en "Add/Remove Programs".
  • Aldonis pli bonan subtenon por kompleksaj senpaŝaj klavoj.
  • Grandan reordigon al la fontkodo.
2.87 (23-mar-11):
  • Korektis cimon enkondukitan en iu antaŭa versio, kiu kaŭzis ke ne eblis tajpi literon kiu ne estas inter A-Z en iujn tekstkampojn de la agordfenestro.
2.86 (23-mar-11):
  • Aldonis eblon facile entajpi literon kiu estas agordita kiel rekta klavo, per Alt Gr.
  • La opcio "Alt Gr + supersignenda litero" nun plene kongruas kun "Alglui literon el tondujo".
  • Riparis malgrandan cimon kiu kaŭzis ke la tekskampo "milisekundoj" en la fenestro "Alglua Metodo" estis neaktiva eĉ kiam la opcio "Remeti enhavon de tondujo post algluo" estis elektita.
2.85 (22-mar-11):
  • Korektis longdaŭran cimon kiu iafoje kaŭzis ke supersigno ne aperas kiam estas elektita "Alglui literon el tondujo" kune kun la subopcio Ctrl+V.
  • Rusa/cirila transliterumado nun malŝaltiĝas kiam la programo estas ŝaltita/malŝaltita. Tio donas rimedon rapide forigi la transliterumadon se ĝi akcidente ŝaltiĝas.
  • La opcio "Remeti enhavon de tondujo post algluo" nun estas elektita defaŭlte.
  • Korektis cimon kiu kaŭzis ke ne eblis forviŝi literon el la "rektaj klavoj" de la agordofenestro kiam estis aktiva Caps Lock.
  • Reordigis la fontkodojn iomete.
2.84 (20-mar-11):
  • Korektis cimon kiu kaŭzis ke neliteraj rektaj klavoj ne funkciis ĝuste se estis premata Shift aŭ estis aktiva Caps Lock.
2.83 (18-mar-11):
  • Korektis cimon kiu kaŭzis la programon ankoraŭ funkcii en la fono post haltigo.
  • Korektis eventualan eraromesaĝon en la instalilo, kiu aperis kiam ne eblis haltigi la programon se ĝi jam ankoraŭ funkciis pro la ĉi-supra cimo.
  • Korektis malgrandan cimon, kiu kaŭzis ke supersigno iafoje ne aperas post uzo de Alt Gr por supersigni alian literon en la klavaranĝo.
2.82 (18-mar-11):
  • Korektis cimon kiu kaŭzis kolizion kun la senpaŝaj klavoj de iuj klavaranĝoj.
2.81 (17-mar-11):
  • Korektis cimon kiu kaŭzis Latin-3-ajn literojn ĝuste aperi nur kiam estas elektita la opcio "Alglui literon el tondujo".
  • Ŝanĝis la metodon ŝalti/malŝalti transliterumadon de rusaj/cirilaj literoj, por igi ĝin malpli akcidente ŝaltebla. La metodo nun estas dekstra Ctrl 3-foje, kaj poste Numpad 7 por rusa, aŭ Numpad 8 por cirila.
2.80 (01-sep-09):
  • Plisimpligis kaj ĝisdatigis la helpdosierojn.
2.79 (26-aŭg-09):
  • Korektis cimon kiu kaŭzis kolizon kun la klavo Shift en certaj komputiloj.
2.78 (19-aŭg-09):
  • Korektis cimon kiu kaŭzis la programon funkcii malĝuste en Vindozo 7.
2.77 (07-aŭg-09):
  • Korektis cimon kiu kaŭzis problemojn kun la klavo Shift, en Vindozo Vista.
  • Korektis cimeton en la fenestro "Pri Tajpi" kiu kaŭzis Esperantan tekston aperi sen supersignoj.
2.76 (06-aŭg-09):
  • Korektis cimon kiu kaŭzis la opcion "Ripeto de sufikso forigas supersignon" funkcii malĝuste en Vindozo Vista.
2.75 (04-aŭg-09):
  • Aldonis eblon ŝanĝi la lingvon de la interfaco, kaj helpdosiero. Oni nun povas elekti inter Esperanto kaj la angla, per klako je bildeto en la agord-fenestro.
  • Aldonis tekston "Aktiva" al la "tooltip", kiu aperas kiam la muskursoro restas ĉe bildeto en la sistema taskopleto. Antaŭe en aktiva stato la teksto estis nur "Tajpi". La teksto nun legiĝas "Tajpi - Aktiva".
  • Korektis kelkajn malgrandajn cimojn.
  • Faris ĝeneralan reordigon al la fontkodo.
  • Ĝisdatigis la helpdosieron.
2.74 (25-jul-09):
  • Korektis cimon kiu kaŭzis aperon de erarofenestro kiam la programo fermiĝis, kun mesaĝo "Run-time error '424': Object required."
2.73 (24-jul-09):
  • Korektis cimon kiu kaŭzis aperon de la fenestro "Alglua Metodo" kraŝigi la programon en certaj komputiloj.
2.72 (23-jul-09):
  • Korektis cimaĉon kiu en iuj kazoj kaŭzis Tajpi tuj fermiĝi je komenciĝo, postlasante la bildeton en la sistema taskopleto kiu malaperis kiam la uzulo provis klaki ĝin per la muso.
  • Kelkaj korektoj al teksto en la programo.
  • Ĝisdatigis la helpdosierojn.
2.71 (23-jun-09):
  • Kelkajn korektojn al teksto en la programo kaj helpdosieroj.
  • Ŝanĝis la defaŭltan staton de la opcio "Starti aŭtomate". Ĝi nun estas elektita defaŭlte.
  • Aldonis opcion en la instalilon por funckiigi Tajpi je la finiĝo de la instala procedo.
2.7 (23-jun-09):
  • Plurajn korektojn al teksto en la programo kaj helpdosieroj.
  • Aldonis eblon specifi la metodon kiun Tajpi uzas kiam ĝi algluas la literon el la sistema tondujo, kaj eblon remeti la enhavon de la tondujo post la algluo.
  • Tajpi nun sonas kiam ŝaltita.
  • Korektis cimon kiu kaŭzis la programon fermiĝi kiam la agord-fenestro estis fermita per la menuo de la fenestro-bildeto, aŭ per aliaj rimedoj, kiel reprogramita musbutono.
  • La instalilo kaj malinstalilo nun fermos Tajpi se ĝi jam funckias. Tio certigas ke la dosieroj estos ĝuste forviŝitaj aŭ anstataŭigitaj.
  • Ŝanĝis la konduton de la opcio "Ripeto de sufikso forigas supersignon". Oni nun devas premi la saman sufikson kiu estis uzita por supersigni la literon.
  • Aldonis klavkomandojn al butonoj kaj markobutonoj de la interfaco, kiuj estis akcidente ellasitaj.
  • Grandan plibonigon kaj reordigon de la fontkodo de la programo.
  • Ĝisdatigis la helpdosierojn.
2.68 (11-jun-09):
  • Denove ŝanĝis la metodon de la skrektaj klavpremoj. Antaŭe oni devis premi LShift+RShift+literon. Sed tio iom discriminacias kontraŭ unumanuloj, do la nova metodo estas premi Ctrl kvinfoje (aŭ dekstran aŭ maldekstran), kaj sekve premi la literon. Do 5 x Ctrl kaj R por ŝalti rusajn transliterumitajn literojn.
  • Iomete reordigis la internaĵojn de la programo (kaj preĝis ke mi ne enkonduku pliajn cimojn per tio).
  • Ĝisdatigis la helpdosierojn.
2.67 (11-jun-09):
  • Reŝanĝis la metodon de klavpremo por la "sekretaj klavpremoj", kiu estis fuŝita en versio 2.66.
2.66 (11-jun-09):
  • Korektis cimon kiu kaŭzis la tutan programon fermiĝi se la agord-fenestro estis malfermita per dufoja klako al la bildeto en la supra-maldekstra angulo de la fenestro.
  • Aldonis pliajn "sekretajn klavpremojn". Dufoje premu Shift kaj poste S por montri ilin.
2.65 (09-jun-09):
  • Korektis cimon kiu kaŭzis iujn klavojn aliajn ol la sufiks-klavoj, povi forigi la supersignon je premo.
  • Ĝisdatigis la helpdosierojn.
2.64 (04-jun-09):
  • Kiam Tajpi komenciĝas, se la programo estas jam funkcianta ĝi estos fermita kaj la nova procedo anstataŭos ĝin. Tio certigas ke ĉiam estos maksimume nur unu funkcianta procezo de la programo.
  • Korektis tekston en la agordo-fenestro "Latin-3" al "Latina-3".
  • Ĝisdatigis la helpdosierojn.
  • Tajpi ekde ĉi tiu versio nun estas eldonata kun sia fontkodo laŭ la kondiĉoj de la GNU GPL versio 3 aŭ ajna posta versio.
2.63 (18-maj-09):
  • Korektis cimon kiun mi enkondukis en version 2.62, koncerne la cirilaj ekvivalentoj de la esperantaj supersignaj literoj.
2.62 (17-maj-09):
  • Korektis kelkajn malgrandajn cimojn kaj faris ĝeneralan ordigon de la internaĵoj de la programo.
2.61 (16-maj-09):
  • Korektis strangan cimon, ŝajne enkondukitan en iu antaŭa ĝisdatigo, kiu kaŭzis la opcion "Ripeto de sufikso forigas supersignon" esti tute ignorata.
2.6 (15-maj-09):
  • Aldonis povon entajpi supersignajn literojn per Alt Gr+klavo. Oni nun povas premi ekzemple Alt Gr+C por aperigi la literon ĉ.
2.5 (13-maj-09):
  • Ŝanĝis la metodon de klavpremo, por la klavkomando kiu ŝaltas la programon.
  • Korektis cimon kiu kaŭzis aperon de malĝustaj HTML-aj surogatoj kiam oni tajpis en transliterumitaj literoj.
  • Aldonis plian metodon de enigo por cirilaj literoj. Oni nun povas premi LShift+RShift+R por nur cirilaj literoj el la rusa alfabeto.
2.41 (11-maj-09):
  • Tajpi nun povas agnoski senpaŝajn klavojn kiel prefiksojn por esperantaj supersignaj literoj. Se la supersignebla litero apartenas al kaj la lingvo de la sistema klavarfasono kaj la esperanta alfabeto, la esperanta litero havas prioritaton.
2.4 (09-maj-09):
  • Aldonis povon entajpi transliterumitajn cirilajn literojn. Por ŝalti premu LShift+RShift+C.
2.3 (08-maj-09):
  • Aldonis la opcion "Igi malvidebla la prefiksan literon".
  • Korektis cimeton, kiu kaŭzis la tekst-kampojn de la rektaj klavoj ne majuskligi la entajpitan literon.
2.23 (07-maj-09):
  • Korektis cimon kiu kaŭzis supersignajn literojn aperi eĉ kiam la uzanto uzis klavaranĝon kiu ne enhavas c, g, h, j, s aŭ u, aŭ la sufiksajn/prefiksajn literojn.
  • Ŝanĝis la metodon de enigo, kiun la programo uzas kiam la opcio "alglui el tondbufro" estas elektita. Nun ne estas uzata la metodo Ctrl+V, sed anstataŭe Shift+Insert.
2.22 (07-maj-09):
  • Rekompilis la helpon al dosiero .chm.
2.21 (07-May-09):
  • Korektis plian cimon pri la senpaŝaj klavoj. Nun oni povas tajpi senpaŝan klavon + Space, kaj aperos sole la senpaŝ-klava litero.
2.2 (06-maj-09):
  • Korektis aĉan cimegon, kiu kaŭzis kolizion kun la "senpaŝaj klavoj" kiuj estas en certaj klavaranĝoj kiel la germana, brazila ktp.
  • Korektis la tekston en la "tooltip" de la bildeto en la rapidlanĉa breto. Antaŭe ĝi legiĝis "My Program". Korektita al "Tajpi".
2.1 (04-maj-09):
  • Kelkaj korektoj al literumaj / tradukaj eraroj en la interfaca teksto.
  • Plibonigis la instalilon per opcioj por meti bildeton sur la skribtablon kaj rapidlanĉan breton ("quick launch bar"), kaj aŭtomata forviŝo de la agordodosiero kaj registrejaj ŝlosiloj kiuj estis postlasataj en la malinstalo.
2.0 (01-maj-09):
  • Tute reverkis Tajpi en programlingvo VB6, kaj aldonis novan interfacon kiu plimalpli sekvas tiun de Ek, kun ĝenerala plisimpligo.
  • Nun nur kongrua kun Vindozo 2000, XP, Vista kaj 7. Tajpi ne subtenas Win9x, ME aŭ NT.
  • Aldonis la opcion "Rektaj klavoj".
  • Igis "ripeto de sufikso forigas supersignon" opcia.
  • Aldonis la opcion "Aŭtomata aŭ/eŭ".
  • Aldonis la opcion enigi la supersignan literon per aŭ rekta enigo, aŭ algluo el la sistema tondujo.
  • Aldonis opcion "Aŭtomata starto". Ĉi tiu funckias per registreja ŝlosilo ("registry key") en HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Run \ Tajpi.
  • Aldonis opcion "Klavkomando".
  • Kreis instalilon por Tajpi, per Inno Setup. La eldonata produkto nun estas memekstrakta dosiero kiu instalas la programon kaj metas bildetojn en la komenc-menuon kaj sur la vindozan skribtablon.
1.0 (08-aŭg-08):
  • Unua versio de Tajpi, verkita per AutoHotkey.
  • Instalado
  • Agordo
  • ← Hejmen

© 2008- Thomas James Ĝisdatiĝis je 10-jun-2016
tmj2005@gmail.com